Community Help

Welcome to the OdooPBX forum!

This community is for OdooPBX users and developers.
Share and discuss issues, features, configuration, ideas, etc.

1

Recordings data not showing in OdooPBX when using custom storage directory

Avatar
Pixel Foundry

Hello,

we have a custom storage path set to save PBX Call Recordings, different from the default one.

Currently the absolute path for that dir is:


/opt/izpbx/data/izpbx/var/spool/asterisk/monitor/

and it's organized then in a structure like:


year/month/day

the volume (var) is mounted under folder "data" and, if accessed through the container, the path is:


/var/spool/asterisk/monitor/

with this configuration we are not able to see any recordings under the appropriate menu in Odoo PBX module:


Avatar
Discard
1Answer
0
Avatar
Max Lit
Best Answer

Hi! Thanks for your question.

1. Check that you have enabled call recordings transfer from Asterisk to Odoo (PBX -> Settings -> General -> Calls tab -> Record Calls option).

2.Make sure the OdooPBX Agent has the proper access to the recordings folder. If it's inside docker enter the container (docker-compose exec pbx bash)  and try to go to the folder as it's seen by the asterisk. Make sure the Agent has the same path mapping. So it must be like that:

volumes:
- /opt/izpbx/data/izpbx/var/spool/asterisk/monitor/:/opt/izpbx/data/izpbx/var/spool/asterisk/monitor/

This is because Asterisk sets the abs path in VarSet AMI message and the Agent will try to take the recording from this path.

Hope this helps.

Avatar
Discard